Setting up local Eclipse clients to work with Jazz source control

Last updated: 13 July 2015

If you use Jazz Source Control Management (SCM) for your IBM® Bluemix™ DevOps Services project, you can either work locally and deliver changes through Eclipse or work by using the integrated Web IDE. If you work locally and deliver changes through Eclipse, you can install the IBM® Rational Team Concert™ plug-in for version control.

If you use the Track & Plan feature to manage your project plans and work items, you can also access your work items from Eclipse.

Installing the Rational Team Concert plug-in

Before you begin

The plugin is based on Rational Team Concert 5.0.2.

Installing the plug-in

  1. In Eclipse, click Help > Install New Software.

  2. In the Install window, complete these steps:

    1. In the Work with field, enter https://jazz.net/downloads/rational-team-concert/5.0.2/5.0.2/p2.
    2. Press Enter to load the contents of the update site.
    3. Select the Rational Team Concert Client feature check box.
    4. Select the Group items by category check box.
    5. Click Next and click Next again.
    6. Review the license terms. If you agree to the terms, accept them.
    7. Click Finish to install the plug-in.
  3. If you see a security warning message, click OK.

  4. If you are prompted to restart Eclipse, click Yes.

Connecting to your DevOps Services projects from Eclipse

From Eclipse, you can connect to your projects in two ways:

  • Use the Manage IBM DevOps Services Projects tool
  • Accept a team invitation

After you connect to your project, you can access its work items.

Before you begin

The project must use a Jazz Source Control Management (SCM) repository.

Option 1: Connecting by using the Manage IBM DevOps Services Projects tool

  1. In the Eclipse Workbench, click Window > Show View > Other > Team Artifacts.

  2. Click the Manage IBM DevOps Services Projects icon. Manage JazzHub Projects button within the Team Artifacts View

  3. In the Manage IBM DevOps Services Projects window, enter your alias and IBM id password to sign in to Bluemix DevOps Services, and then click Next

  4. Select the Bluemix DevOps Services projects to connect to and click Finish.

Option 2: Connecting by accepting a team invitation

  1. In DevOps Services, browse to your project's Overview page.

  2. Click Configure eclipse client. Configure eclipse button on the project overview

  3. Copy the text for the project invitation.

  4. In Eclipse, click File > Accept JazzHub Client Configuration. If you don't see that menu option, click File > Accept Team Invitation.

  5. Paste the invitation text, click Next, and then click Finish.

  6. Enter your alias and IBM id password to sign in to Bluemix DevOps Services.

You are now connected to your Bluemix DevOps Services project in Eclipse. To see the new repository connection and project area, click the Team Artifacts tab.

Loading DevOps Services projects in Eclipse

Before you begin

Connect to a project from Eclipse. The project must have the Track & Plan feature enabled.

Creating a repository workspace

  1. In the Eclipse Workbench, click Window > Show View > Other > Team > Team Artifacts.

  2. Expand your project area to show the Source Control folder.

  3. Right-click the Source Control folder, and click New > Repository Workspace.

  4. Select the stream to flow to and click Next.

  5. Specify a new name for your repository workspace and click Finish.

  6. Complete the wizard.

Loading projects

  1. Click Find and load Eclipse projects and click Next.

  2. Select the Eclipse projects to load and click Finish.

  3. Click the Package tab or the Project Explorer tab to create or browse files and edit code.

Delivering changes

  1. Make changes to the files. You can edit them with an Eclipse editor or an external editor of your choice.
  2. In the Package tab or Project Explorer view, refresh the files.
  3. In the Pending changes view, right-click the unresolved changes and click Check in and New changeset.
  4. Add a comment to the changeset.
  5. Right-click the changeset and click Deliver.

Opening DevOps Services work item queries in Eclipse

Before you begin

Connect to a project from Eclipse.

Opening queries

  1. In the Team artifacts view, expand a project and Work Items.

  2. Create a query or open an existing query.

Limitations to change and configuration management features

In DevOps Services projects, certain change and configuration management features that are in Rational Team Concert might not be available.

Project-area save permissions are not available

  • Team areas cannot be created.
  • Process customization for work items, workflows, approval and review requirements, pre- and post- conditions, and so on, cannot be configured.
  • In Eclipse, timelines cannot be edited directly. To manage timelines, in DevOps Services, click TRACK & PLAN, and open the Sprint Planning view.
  • Membership operations are not available. You can invite users to join a project from the DevOps Services project. For more information about user-role privileges, see Administering a project in Bluemix DevOps Services.

Exception: You can change work-item categories in the project-area editor.

  • Personal dashboards cannot be accessed.