Setting up local Eclipse clients to work with Jazz source control

Last modified: 16 May 2015

If you use Jazz Source Control Management (SCM) for your IBM® Bluemix™ DevOps Services project, you can either work locally and deliver changes through Eclipse or work by using the integrated Web IDE. If you work locally and deliver changes through Eclipse, you can install the IBM® Rational Team Concert™ plug-in for version control.

If you use the Track & Plan feature to manage your project plans and work items, you can also access your work items from Eclipse.


Contents


Install the Rational Team Concert plug-in

Before you begin:

The plug-in is based on Rational Team Concert 5.0.2.

Install the plug-in:

  1. In Eclipse, click Help > Install New Software.

  2. In the Install window, complete these steps:

    1. In the Work with field, enter https://jazz.net/downloads/rational-team-concert/5.0.2/5.0.2/p2 and press Enter.
    2. Select the Rational Team Concert Client Feature check box.
    3. Select the Group items by category check box. Installing the Rational Team Concert Client Feature
    4. Click Next and click Next again.
    5. Review the license terms. If you agree to the terms, accept them.
    6. Click Finish to install the plug-in.
  3. If you see a security warning message, click OK.

  4. If you are prompted to restart Eclipse, click Yes.


Connect to your DevOps Services projects from Eclipse

Before you begin:

The project must use a Jazz Source Control Management (SCM) repository.

From Eclipse, you can connect to your projects in two ways:

  • Use the Manage IBM DevOps Services Projects tool
  • Accept a team invitation

After you connect to your project, you can access its work items.

Option 1: Connect by using the Manage IBM DevOps Services Projects tool

  1. In the Eclipse workbench, click Window > Show View > Other. Type team, select Team Artifacts, and click OK.

  2. Click the Manage IBM DevOps Services Projects icon. Manage JazzHub Projects button within the Team Artifacts View

  3. In the Manage IBM DevOps Services Projects window, type your alias and IBM id password to sign in to DevOps Services, and then click Next

  4. Select the DevOps Services projects to connect to and click Finish.

Option 2: Connect by accepting a team invitation

  1. In DevOps Services, go to your project's Overview page.

  2. Click Configure eclipse client. Configure eclipse button on the project overview

  3. Copy the text for the project invitation.

  4. In Eclipse, click File > Accept JazzHub Client Configuration. If you don't see that menu option, click File > Accept Team Invitation.

  5. Paste the invitation text, click Next, and then click Finish.

  6. Sign in to DevOps Services by typing your alias and IBM id password .

You are now connected to your DevOps Services project in Eclipse. To see the new repository connection and project area, click the Team Artifacts tab.


Load DevOps Services projects in Eclipse

Before you begin:

Connect to a project from Eclipse. The project must have the Track & Plan feature enabled.

Create a repository workspace:

  1. In the Eclipse workbench, click Window > Show View > Other. Type team, select Team Artifacts, and click OK.

  2. Expand your project area to show the Source Control folder.

  3. Right-click the Source Control folder, and click New > Repository Workspace.

  4. Select the stream to flow to and click Next.

  5. Specify a new name for your repository workspace and click Finish.

  6. Follow the steps in the wizard to finish creating the connection.

Load projects:

  1. In the Load Repository Workspace window, click Find and load Eclipse projects and click Next.

  2. Select the Eclipse projects to load and click Finish.

  3. To create or browse files or to edit code, click the Package tab or the Project Explorer tab.


Deliver changes

  1. Make changes to the files. You can edit them in an Eclipse editor or in an external editor of your choice.
  2. On the Package tab or in the Project Explorer view, refresh the files.
  3. In the Pending Changes view, right-click the unresolved changes. Click Check in and then click New changeset.
  4. Add a comment to the change set.
  5. Right-click the change set and click Deliver.

Open DevOps Services work item queries in Eclipse

Before you begin:

Connect to a project from Eclipse.

Open queries:

  1. In the Team Artifacts view, expand a project and then expand Work Items.

  2. Create a new query or open existing queries.


Need help? Ask a question in the IBM Bluemix DevOps Services forum. Have feedback? Report a bug or share your idea in the IBM Bluemix DevOps Services project.

© Copyright IBM Corporation 2013, 2015.